HDOJ 2136 Largest prime factor


Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5021    Accepted Submission(s): 1772


Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 

Input
Each line will contain one integer n(0 < n < 1000000).
 

Output
Output the LPF(n).
 

Sample Input
12345
 

Sample Output
01213
 

Author
Wiskey
 

Source
 


#include <cstdio>

#define N 1000001

int x[N]={0};

int main()
{
    int i,j,n;
    n=0;
    for(i=2;i<N;i++)
    while(x==0)
    {
        n++;
        for(j=i;j<N;j+=i)
            x[j]=n;
    }

    while(scanf("%d",&n)!=EOF)
    printf("%d\n",x[n]);

    return 0;
}

posted @ 2013-05-01 19:22  码代码的猿猿  阅读(171)  评论(0编辑  收藏  举报