HDOJ 1061 Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23619    Accepted Submission(s): 8998


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
234
 

Sample Output
76
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

Author
Ignatius.L

 #include<iostream>

using namespace std;

int main()
{
    int n;
    cin>>n;
    for(int k=0;k<n;k++)
    {
        int m;
        cin>>m;
        int t=(m-1)%4;

        m=m%10;

        //cout<<t<<" "<<m<<endl;

        int l;
        switch(t)
        {
        case 0:
            l=m; break;
        case 1:
            l=m*m%10; break;
        case 2:
            l=m*m*m%10; break;
        case 3:
            l=m*m*m*m%10; break;
        }

        cout<<l<<endl;

    }
    return 0;
}

posted @ 2013-04-12 08:24  码代码的猿猿  阅读(168)  评论(0编辑  收藏  举报