【POJ】[2503]Babelfish

Babelfish

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 40481 Accepted: 17238

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.
简单的STL应用,可用map+string水过读取字典的时候可用c=getchar()读取然后判断是否为‘\n’来控制结束如果不是则继续把串读取完再合并起来

#include<stdio.h>
#include<map>
#include<string>
#include<algorithm>
using namespace std;
char s1[12],s2[12];
int main() {
	map<string,string>q;
	char c;
	while(c=getchar(),c!='\n')	{
		scanf("%s %s",s1,s2);
		getchar();
		string t1=s1;
		s1[0]=c,s1[1]='\0';
		t1=s1+t1;
		string t2=s2;
		q[t2]=t1;
	}
	while(scanf("%s",s1)!=EOF) {
		string res=q[s1];
		if(res.length()>0)
			printf("%s\n",res.c_str());
		else
			printf("eh\n");
	}
	return 0;
}






题目地址:【POJ】[2503]Babelfish
查看原文:http://www.boiltask.com/blog/?p=1443
posted @ 2016-07-28 09:15  BoilTask  阅读(14)  评论(0编辑  收藏  举报