【杭电】[5326]Work
原文地址:http://www.boiltask.com/blog/?p=1982
Work
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1691 Accepted Submission(s): 1009
Problem Description
It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.
Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.
1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
Output
For each test case, output the answer as described above.
Sample Input
7 2
1 2
1 3
2 4
2 5
3 6
3 7
Sample Output
2
寻找父节点时则把父节点的层数加1
这样ran数组中便可保存其下面有多少人
最后查找ran[i]==k的个数即可
#include<stdio.h>
int par[120],ran[120];
void find(int m) {
if(m!=par[m]) {
ran[par[m]]++;
find(par[m]);
}
}
void unite(int x,int y) {
if(x!=y)
par[y]=x;
}
int main() {
int n,k;
while(scanf("%d %d",&n,&k)!=EOF) {
for(int i=1; i<=n; i++) {
ran[i]=0;
par[i]=i;
}
for(int i=1; i<n; i++) {
int a,b;
scanf("%d %d",&a,&b);
unite(a,b);
}
for(int i=1; i<=n; i++)
find(i);
int res=0;
for(int i=1; i<=n; i++) {
if(ran[i]==k)
res++;
}
printf("%d\n",res);
}
return 0;
}
题目地址:【杭电】[5326]Work