PAT 1138 Postorder Traversal [比较]

1138 Postorder Traversal (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

 题目大意:给出二叉树的前序和中序,输出后序遍历的第一个节点。

//这道题看似简单,但是容易超时。

复制代码
#include <iostream>
#include <vector>
#include<cstdio>
using namespace std;

vector<int> pre,in,post;
void getPost(int inL,int inR,int preL,int preR){
    if(inL>inR||post.size()!=0)return ;
    //if(preL>preR)return ;
    int i=0;
    while(in[i]!=pre[preL])i++;
    getPost(inL,i-1,preL+1,preL+i-inL);
    getPost(i+1,inR,preL+i-inL+1,preR);
    post.push_back(pre[preL]);
}
int main() {
    int n;
    cin>>n;
    int t;
    for(int i=0;i<n;i++){
        cin>>t;
        pre.push_back(t);
    }
    for(int i=0;i<n;i++){
        cin>>t;
        in.push_back(t);
    }
    getPost(0,n-1,0,n-1);
    cout<<post[0];
    return 0;
}
复制代码

 

//这样写取判断总有最后两个或者倒数第二个测试点过不去,运行超时。

//尝试想传递&引用,发现不行,报错:

\main.cpp|12|error: invalid initialization of non-const reference of type 'int&' from an rvalue of type 'int'|

 

改成以下之后,也就是将函数参数减少一个:

复制代码
#include <iostream>
#include <vector>
#include<cstdio>
using namespace std;

vector<int> pre,in,post;
void getPost(int inL,int inR,int pr){
    if(inL>inR||post.size()>0)return ;
    //if(preL>preR)return ;
    int i=0;
    while(in[i]!=pre[pr])i++;
    getPost(inL,i-1,pr+1);
    getPost(i+1,inR,pr+i-inL+1);
    post.push_back(pre[pr]);
}
int main() {
    int n;
    cin>>n;
    int t;
    for(int i=0;i<n;i++){
        cin>>t;
        pre.push_back(t);
    }
    for(int i=0;i<n;i++){
        cin>>t;
        in.push_back(t);
    }
    getPost(0,n-1,0);
    cout<<post[0];
    return 0;
}
复制代码

 

倒数第二个测试点超时。

//忽然想起,将i初始化时改为inL,然后就AC了!!!这样遍历的就少了。

主要问题就是i的初始化问题,一定要初始化为inL,修改之后第一个代码也过了,说明运行超时不是函数传参参数个数的问题。

posted @   lypbendlf  阅读(195)  评论(0编辑  收藏  举报
编辑推荐:
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
阅读排行:
· 无需6万激活码!GitHub神秘组织3小时极速复刻Manus,手把手教你使用OpenManus搭建本
· C#/.NET/.NET Core优秀项目和框架2025年2月简报
· Manus爆火,是硬核还是营销?
· 终于写完轮子一部分:tcp代理 了,记录一下
· 【杭电多校比赛记录】2025“钉耙编程”中国大学生算法设计春季联赛(1)
点击右上角即可分享
微信分享提示