PAT 1035 Password [字符串][简单]

1035 Password (20 分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following Mlines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

 题目大意:由于密码o和0之类很相似,所以给出规则将4种字符进行替换,并且输出替换之后的。

#include <iostream>
#include <vector>
#include <map>
using namespace std;

int main() {
    int n;
    cin>>n;
    string na,pd;
    map<char,char> mp;
    mp['1']='@';
    mp['0']='%';
    mp['l']='L';
    mp['O']='o';
    int ct=0;
    for(int i=0;i<n;i++){
        cin>>na>>pd;
        bool flag=false;
        for(int j=0;j<pd.size();j++){
            if(mp.count(pd[j])==1){
                pd[j]=mp[pd[j]];
               flag=true;
            }
        }
        if(flag){
            cout<<na<<" "<<pd<<'\n';
            ct++;
        }
    }
    if(ct==0){
        if(n==1){
            cout<<"There is 1 account and no account is modified\n";
        }else {
            cout<<"There are "<<n<<" accounts and no account is modified\n";
        }
    }
    return 0;
}
View Code

 

 //第一次提交之后只过了12两个测试点,得5分,这是为什么呢?

 AC:

#include <iostream>
#include <vector>
#include <map>
using namespace std;

int main() {
    int n;
    cin>>n;
    string na,pd;
    map<char,char> mp;
    vector<string> vs;
    mp['1']='@';
    mp['0']='%';
    mp['l']='L';
    mp['O']='o';
    for(int i=0;i<n;i++){
        cin>>na>>pd;
        bool flag=false;
        for(int j=0;j<pd.size();j++){
            if(mp.count(pd[j])==1){
                pd[j]=mp[pd[j]];
               flag=true;
            }
        }
        if(flag){
            //cout<<na<<" "<<pd<<'\n';
            vs.push_back(na+" "+pd);
        }
    }
    if(vs.size()==0){
        if(n==1){
            cout<<"There is 1 account and no account is modified\n";
        }else {
            cout<<"There are "<<n<<" accounts and no account is modified\n";
        }
    }else{
        cout<<vs.size()<<'\n';
        for(int i=0;i<vs.size();i++){
            cout<<vs[i]<<'\n';
        }

    }
    return 0;
}

 

因为最后那个没输出vs.size()啊。

posted @ 2018-10-12 09:39  lypbendlf  阅读(178)  评论(0编辑  收藏  举报