POJ2955 Brackets
题目
Description
We give the following inductive definition of a “regular brackets” sequence:the empty sequence is a regular brackets sequence,if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, andif a and b are regular brackets sequences, then ab is a regular brackets sequence.no other sequence is a regular brackets sequenceFor instance, all of the following character sequences are regular brackets sequences:(), [], (()), ()[], ()[()]
while the following character sequences are not:(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.Given the initial sequence ([([]])]
, the longest regular brackets subsequence is [([])]
.
Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (
, )
, [
, and ]
; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.
Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.
Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6
Source
题解
知识点:区间dp。
一道经典区间dp,设 \(dp[i][j]\) 为区间 \([i,j]\) 的最大匹配数。有转移方程:
注意这两种情况的最大不互斥,即可能左右匹配上了但加二以后还不如用下面拆开来的一种匹配的多,所以都要遍历一遍。
时间复杂度 \(O(|s|^3)\)
空间复杂度 \(O(|s|^2)\)
代码
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
string s;
int dp[107][107];
int main() {
std::ios::sync_with_stdio(0), cin.tie(0), cout.tie(0);
while (cin >> s, s != "end") {
memset(dp, 0, sizeof(dp));
for (int i = 0;i < s.size();i++) dp[i][i] = 0;
for (int l = 2;l <= s.size();l++) {
for (int i = 0;i < s.size() - l + 1;i++) {
int j = i + l - 1;
if (s[i] == '(' && s[j] == ')' || s[i] == '[' && s[j] == ']') dp[i][j] = max(dp[i][j], dp[i + 1][j - 1] + 2);
for (int k = i;k < j;k++)
dp[i][j] = max(dp[i][j], dp[i][k] + dp[k + 1][j]);
}
}
cout << dp[0][s.size() - 1] << '\n';
}
return 0;
}
本文来自博客园,作者:空白菌,转载请注明原文链接:https://www.cnblogs.com/BlankYang/p/16586817.html