POJ1163 The Triangle

题目链接

题目

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

IOI 1994

题解

知识点:线性dp。

qwq当年的顶级难题。

首先把三角形搞成直角三角形,然后下标从 1 开始,方便处理。

发现某一个位置的最大值可以由其上一个位置的最大值推得,具有最优子结构;前一个数最大值是如何得到的我们不关心,没有后效性,因此动态规划可用。

模拟一下直角三角的转移路径,显然有转移方程:

dp[i][j]=max(dp[i1][j1],dp[i1][j])

时间复杂度 O(n2)

空间复杂度 O(n2)

代码

#include <iostream>
#include <algorithm>
using namespace std;
int dp[107][107];
int main() {
std::ios::sync_with_stdio(0), cin.tie(0), cout.tie(0);
int n;
cin >> n;
for (int i = 1;i <= n;i++) {
for (int j = 1;j <= i;j++) {
cin >> dp[i][j];
dp[i][j] += max(dp[i - 1][j - 1], dp[i - 1][j]);
}
}
int ans = 0;
for (int i = 1;i <= n;i++) {
ans = max(ans, dp[n][i]);
}
cout << ans << '\n';
return 0;
}
posted @   空白菌  阅读(26)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
点击右上角即可分享
微信分享提示