POJ2785 4 Values whose Sum is 0

题目

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source

Southwestern Europe 2005

题解

知识点:二分,分治。

直接枚举是 \(O(n^4)\) ,枚举前三个最后一个二分查找是 \(O(n^3 \log n)\) ,都是不可行的。

考虑两两枚举,右边预处理出所有对并排序,左边两列枚举出一组数对,在右边数对查找匹配的数对,复杂度是 \(O(n^2 \log n)\),可行。

时间复杂度 \(O(n^2 \log n)\)

空间复杂度 \(O(n^2)\)

代码

#include <bits/stdc++.h>

using namespace std;

int a[4007][4 + 7];
int b[16000007];

int main() {
    std::ios::sync_with_stdio(0), cin.tie(0), cout.tie(0);
    int n;
    cin >> n;
    for (int i = 0;i < n;i++) cin >> a[i][0] >> a[i][1] >> a[i][2] >> a[i][3];
    int cnt = 0;
    for (int i = 0;i < n;i++)
        for (int j = 0;j < n;j++)
            b[cnt++] = a[i][2] + a[j][3];
    sort(b, b + cnt);
    long long ans = 0;
    for (int i = 0;i < n;i++) {
        for (int j = 0;j < n;j++) {
            int sum = a[i][0] + a[j][1];
            ans += upper_bound(b, b + cnt, -sum) - lower_bound(b, b + cnt, -sum);
        }
    }
    cout << ans << '\n';
    return 0;
}
posted @ 2022-06-28 14:43  空白菌  阅读(20)  评论(0编辑  收藏  举报