HDU——1027Ignatius and the Princess II(next_permutation函数)

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6191    Accepted Submission(s): 3664

Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

 

Sample Input
6 4 11 8
 

 

Sample Output
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
 
最近学习了下C++的STL模版,知道了迭代器和vector的初步使用。由于还没学到关于序列的知识,只能去搜题解,发现了一个在头文件<algorithm>中神奇的函数next_permutation
 
 

 

 

 
可以看出他的参数为某种迭代器,然后就用STL的vector来取代数组(其实这题用数组也可以,数组的地址就是一种指针,而迭代器是一种广义指针)
用vector的代码如下:
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
int main(void)
{
	int n,m;
	while(cin>>n>>m)
	{
		vector<int>list(n);
		vector<int>::iterator it;
		int k=1;
		for (it=list.begin(); it!=list.end(); it++)
		{
			*it=k;
			k++;
		}
		int COUNT=1;注意此题的 first sequence已经是题中所给的自然增长序列,无需计入
		while (next_permutation(list.begin(),list.end()))
		{
			COUNT++;
			if(COUNT==m)
				break;
		}
		for (it=list.begin(); it!=list.end(); it++)
		{
			if(it!=list.end()-1)
				cout<<*it<<' ';
			else
				cout<<*it<<endl;
		}			
	}
	return 0;
}

 


用数组的代码如下:
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
int main(void)
{
	int n,m;
	while(cin>>n>>m)
	{
		int *list=new int[n];
		int i;
		for (int i=0; i<n; i++)
		{
			list[i]=i+1;
		}
		int COUNT=1;注意此题的 first sequence已经是题中所给的自然增长序列,无需计入
		while (next_permutation(list,list+n))
		{
			COUNT++;
			if(COUNT==m)
				break;
		}
		for (i=0; i<n; i++)
		{
			if(i!=n-1)
				cout<<list[i]<<' ';
			else
				cout<<list[i]<<endl;
		}	
		delete []list;		
	}
	return 0;
}
posted @ 2016-02-03 14:25  Blackops  阅读(142)  评论(0编辑  收藏  举报