HDU——1019Least Common Multiple(多个数的最小公倍数)

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42735    Accepted Submission(s): 16055

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

 

Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
 

 

Sample Output
105 10296
 
这题百度了下有出现n=1的情况,按我之前先取两个数得到第一个公倍数的做法会超时,n=1根本没无法输出。因此要重新写,顺便复习下gcd公式
代码:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
long long gcd(long long a,long long b)
{
  return b?gcd(b,a%b):a;//还是记这个吧,简单易用
}
int main()
{
    int t;
    cin>>t;
    while (t--)
    {
        int n;
        long long  a,tlcm,beg=1;//让beg初始化为1不影响结果并成为第0个数,这样一开始也就可以一个一个地求gcd
        scanf("%d",&n);
        for (int i=0; i<n; i++)
        {
            scanf("%lld",&a);
            beg=(beg*a)/gcd(a,beg);
        }
        cout<<beg<<endl;
    }
    return 0;
}
posted @   Blackops  阅读(215)  评论(0编辑  收藏  举报
努力加载评论中...
点击右上角即可分享
微信分享提示