Censor SCU - 4438

 

frog is now a editor to censor so-called sensitive words (敏感词).

She has a long text (p). Her job is relatively simple -- just to find the first occurence of sensitive word (w) and remove it.

frog repeats over and over again. Help her do the tedious work.

Input

The input consists of multiple tests. For each test:

The first line contains (1) string (w). The second line contains (1) string (p).

((1 <={length of}w, p <= 5 * 10^6), (w, p) consists of only lowercase letter)

Output

For each test, write (1) string which denotes the censored text.

Sample Input

    abc
    aaabcbc
    b
    bbb
    abc
    ab

Sample Output

    a
    
    ab

KMP还是比较难呀,更何况是KMP变形,想了好久。。

复制代码
// Asimple
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <queue>
#include <vector>
#include <string>
#include <cstring>
#include <stack>
#include <set>
#include <map>
#include <cmath>
#define INF 0x3f3f3f3f
#define mod 1000000007
#define debug(a) cout<<#a<<" = "<<a<<endl
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 5000000+5;
ll n, m, T, len, cnt, num, ans, Max, k;
char str[maxn], s[maxn];
int Next[maxn], pre[maxn];

void getNext() {
    int j,k;
    j=0;
    k=-1;
    Next[0]=-1;
    while(j<cnt) {
        if(k==-1||s[j]==s[k]) Next[++j]=++k;
        else k=Next[k];
    }
}

void KMP() {
    getNext();
    int i,j=0, k = 0;    
    char a[maxn];
    for(i=0; i<len; i++, k++) {
        a[k] = str[i];
        while(j>0&&str[i]!=s[j]) j=Next[j];
        if( s[j]==str[i] ) j++;
        if(j==cnt) {
            k -= cnt;
            j=pre[k];
        }
        pre[k] = j;
        a[k+1] = '\0';
    }
    printf("%s\n", a);
}

void input() {
    while( ~scanf("%s%s", s, str) ) {
        cnt = strlen(s);
        len = strlen(str);
        KMP();
    }
}

int main() {
    input();
    return 0;
} 
复制代码

 

posted @   Asimple  阅读(485)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示