Max Sum Plus Plus HDU - 1024

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

InputEach test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n
Process to the end of file. 
OutputOutput the maximal summation described above in one line. 
Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8
 

Hint

Huge input, scanf and dynamic programming is recommended.

 本题的大致意思为给定一个数组,求其分成m个不相交子段和最大值的问题。

用一个数组去寻找当前段的最大值,用另一个数组保存寻找过的最大值。

复制代码
// Asimple
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <queue>
#include <vector>
#include <string>
#include <cstring>
#include <stack>
#define INF 0x3f3f3f3f
#define mod 2016
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1000000+5;
int n, m, T, len, cnt, num, Max;
int dp[maxn], mmax[maxn];
int a[maxn];

void input() {
    while( scanf("%d%d", &m, &n)!=EOF ) {
        for(int i=1; i<=n; i++) {
            scanf("%d", &a[i]);
            dp[i] = 0;
            mmax[i] = 0;
        }
        dp[0] = 0;
        mmax[0] = 0;
        for(int i=1; i<=m; i++) {
            Max = -INF;
            for(int j=i; j<=n; j++) {
                dp[j] = max(dp[j-1]+a[j], mmax[j-1]+a[j]);
                mmax[j-1] = Max;
                Max = max(Max, dp[j]);
            }
        }
        printf("%d\n", Max);
    }
}

int main() {
    input();
    return 0;
} 
复制代码

感谢kuangbin大神的解析http://www.cnblogs.com/kuangbin/archive/2011/08/04/2127085.html

posted @   Asimple  阅读(244)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示