UVA - 748 Exponentiation

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number (0.0 < R < 99.999) and n is an integer such that 0 < n ≤ 25.

Input 

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

 

Output 

The output will consist of one line for each line of input giving the exact value of Rn. Leading zeros and insignificant trailing zeros should be suppressed in the output.

 

Sample Input 

 

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

 

Sample Output 

 

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

有趣的大数幂运算,如果直接用BigDecimal的话会错误,需要进行一点小小的处理。

复制代码
import java.math.BigDecimal;
import java.util.Scanner;

/**
 * 
 * @author Asimple
 * @date ${date}
 * 
 */

public class Main{
    
    public static BigDecimal fun(BigDecimal num, int n) {
        if( n==1 ) return num;
        if( n%2==0 ) return fun(num,n/2).multiply(fun(num,n/2));
        else return fun(num,n/2).multiply(fun(num,n/2)).multiply(num);
    }
    
    static Scanner sc = new Scanner(System.in);
    public static void main(String[] args) {
        BigDecimal a;
        int n;
        while( sc.hasNext() ) {
            a = sc.nextBigDecimal();
            n = sc.nextInt();
            String ans = "";
            ans = fun(a,n).stripTrailingZeros().toPlainString();  
            if(ans.charAt(0) == '0') {  
                int i;  
                for(i=0; i<ans.length(); i++) 
                    if(ans.charAt(i) != '0')
                        break;  
                System.out.println(ans.substring(i));  
            }
            else  System.out.println(ans);  
        }
    }
}
复制代码

 

posted @   Asimple  阅读(220)  评论(0编辑  收藏  举报
编辑推荐:
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· Manus的开源复刻OpenManus初探
· AI 智能体引爆开源社区「GitHub 热点速览」
· 从HTTP原因短语缺失研究HTTP/2和HTTP/3的设计差异
· 三行代码完成国际化适配,妙~啊~
历史上的今天:
2016-05-24 ACM题目————Equations
2016-05-24 ACM题目————STL练习之Ananagrams
点击右上角即可分享
微信分享提示