Kattis之旅——Number Sets

You start with a sequence of consecutive integers. You want to group them into sets.

You are given the interval, and an integer P. Initially, each number in the interval is in its own set.

Then you consider each pair of integers in the interval. If the two integers share a prime factor which is at least P, then you merge the two sets to which the two integers belong.

How many different sets there will be at the end of this process?

Input

One line containing an integer C, the number of test cases in the input file.

For each test case, there will be one line containing three single-space-separated integers A, B, and P. A and B are the first and last integers in the interval, and P is the number as described above.

Output

For each test case, output one line containing the string "Case #X: Y" where X is the number of the test case, starting from 1, and Y is the number of sets.

Limits

Small dataset

1 <= C <= 10

1 <= A <= B <= 1000

2 <= P <= B

Large dataset

1 <= C <= 100

1 <= A <= B <= 1012

B <= A + 1000000

2 <= P <= B

 

 Sample Input 1Sample Output 1
2
10 20 5
10 20 3
Case #1: 9
Case #2: 7

题目大概意思就是——给你一个范围A到B,范围中每个数就是一个集合,再给你一个素数P,如果这个范围的两个数有大于或者等于P的素数因子,那么合并两个数所在的集合作为一个集合。

并查集。

复制代码
#include <iostream>
#include <algorithm>

using namespace std;

typedef long long ll;

static bool test_prime(ll p)
{
    if (p < 2) return false;
    for (ll i = 2; i * i <= p; i++)
        if (p % i == 0)
            return false;
    return true;
}

static int parent[1000001];

static int root(int x)
{
    if (parent[x] < 0)
        return x;
    else
        return parent[x] = root(parent[x]);
}

static void merge(int a, int b)
{
    a = root(a);
    b = root(b);
    if (a == b) return;
    if (parent[a] > parent[b])
        swap(a, b);
    parent[a] += parent[b];
    parent[b] = a;
}

int main()
{
    int cases;
    cin >> cases;

    for (int cas = 0; cas < cases; cas++)
    {
        ll A, B, P;
        cin >> A >> B >> P;

        for (ll i = A; i <= B; i++)
            parent[i - A] = -1;
        for (ll i = P; i <= B - A; i++)
            if (test_prime(i))
            {
                ll t = B - B % i;
                while (t - i >= A)
                {
                    merge(t - A, t - i - A);
                    t -= i;
                }
            }
        ll ans = 0;
        for (ll i = A; i <= B; i++)
            if (parent[i - A] < 0)
                ans++;
        cout << "Case #" << cas + 1 << ": " << ans << "\n";
    }
    return 0;
}
复制代码

 

posted @   Asimple  阅读(284)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示