POJ 2492 A Bug's Life

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

大意就是,题目给出一对又一对的情侣,看看其中是不是有同性恋。

种类并查集。

用一个数组re保存祖先,然后判断两者的祖先是否相等,相等则同性。

复制代码
//Asimple
//#include <bits/stdc++.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <set>
#include <map>
#include <string>
#include <queue>
#include <limits.h>
#include <time.h>
#define INF 0xfffffff
#define mod 10007
#define CLS(a, v) memset(a, v, sizeof(a))
#define debug(a)  cout << #a << " = "  << a <<endl
#define abs(x) x<0?-x:x
using namespace std;
typedef long long ll;
const int maxn = 2005;
int fa[maxn];
int re[maxn];
int n, m, num, T, x, y;

int find(int x) {
    if( fa[x]==x ) return x;
    int t = fa[x];
    fa[x] = find(fa[x]);
    re[x] = ( re[x] + re[t] +1 )%2;
    return fa[x];
}

void make_set(int x, int y) {
    int xx = find(x);
    int yy = find(y);
    fa[xx] = yy;
    re[xx] = (re[y]-re[x])%2;
} 
void input() {
    cin >> T;
    int cas = 1;
    while( cas<= T ) {
        bool f = true;
        cin >> n >> m;
        for(int i=1; i<=n; i++){
            fa[i] = i;
            re[i] = 1;
        }
        for(int i=0; i<m; i++) {
            cin >> x >> y;
            if( find(x)==find(y) ) {
                if( re[x]==re[y] )
                    f = false;
            } else make_set(x, y);
        }
        printf("Scenario #%d:\n", cas++);
        puts(f?"No suspicious bugs found!":"Suspicious bugs found!");
        puts("");
    }
}

int main() {
    input();
    return 0;
}
复制代码

 

posted @   Asimple  阅读(195)  评论(0编辑  收藏  举报
编辑推荐:
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
阅读排行:
· TypeScript + Deepseek 打造卜卦网站:技术与玄学的结合
· Manus的开源复刻OpenManus初探
· AI 智能体引爆开源社区「GitHub 热点速览」
· 从HTTP原因短语缺失研究HTTP/2和HTTP/3的设计差异
· 三行代码完成国际化适配,妙~啊~
点击右上角即可分享
微信分享提示