每日一九度之 题目1042:Coincidence

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:3007

解决:1638

题目描述:

Find a longest common subsequence of two strings.

输入:

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出:

For each case, output k – the length of a longest common subsequence in one line.

样例输入:
abcd
cxbydz
样例输出:
2

经典的dp问题。LCS。相当于dp的入门级题目吧!

复制代码
//Asimple
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <set>
#include <map>
#include <string>
#include <queue>
#include <limits.h>
#define INF 0x7fffffff
using namespace std;
const int maxn = 115;
typedef long long ll;
int n, num;
char s1[maxn], s2[maxn];
int dp[maxn][maxn];

int main(){
    while( cin >> s1 >> s2 ){
        int len1 = strlen(s1);
        int len2 = strlen(s2);
        for (int i=0; i<=len1; ++i)  
            dp[i][0] = 0;  
       for (int j=0; j<=len2; ++j)  
            dp[0][j] = 0; 
        for(int i=1; i<=len1; i++){
            for(int j=1; j<=len2; j++){
                if( s1[i-1] == s2[j-1] ){
                    dp[i][j] = dp[i-1][j-1] + 1;
                } else {
                    dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        printf("%d\n",dp[len1][len2]);
    }
    return 0;
}
复制代码

 

posted @   Asimple  阅读(241)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示