ACM题目————The Blocks Problem

代码参考:http://www.hankcs.com/program/uva-q101-the-blocks-problem.html

 

Description

 

Background 

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem 

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all $0 \leq i < n-1$ as shown in the diagram below:

 
\begin{figure}
\centering
\setlength{\unitlength}{0.0125in} %
\begin{picture}
(2...
...raisebox{0pt}[0pt][0pt]{$\bullet
\bullet \bullet$ }}}
\end{picture}
\end{figure}
Figure: Initial Blocks World

 

The valid commands for the robot arm that manipulates blocks are:

  • move a onto b

    where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

  • move a over b

    where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

  • pile a onto b

    where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.

  • pile a over b

    where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.

  • quit

    terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input 

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output 

The output should consist of the final state of the blocks world. Each original block position numbered i ( $0 \leq i < n$ where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output 

 0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:

 模拟题,直接按题目走就好,但是,为什么不能用队列?

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
//Asimple hash
//#include <bits/stdc++.h>
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <iterator>
#include <deque>
#include <string>
#include <string.h>
#include <vector>
#include <stack>
#include <ctype.h>
#include <queue>
#include <math.h>
#include <stdlib.h>
#include <map>
#include <set>
#include <time.h>
#include <bitset>
#include <list>
 
using namespace std;
typedef long long ll ;
typedef list<int>::iterator iter;
const int maxn = 25;
int n;
list<int> L[maxn];//为什么不能直接用队列?
 
void Print_L()
{
    for(int i=0; i<n; i++)
    {
        cout << i << ":" ;
        for( iter it = L[i].begin(); it !=L[i].end(); it++)
            cout << " " << *it ;
        cout << endl ;
    }
}
 
iter search(int &i, const int& x)
{
    for( i=0; i<n; i++)
    {
        iter it = find(L[i].begin(),L[i].end(), x);//找x
        if(it != L[i].end() ) return it ;
    }
}
 
void restore(const int& i, iter it)
{
    ++ it;
    while( it != L[i].end() )
    {
        L[*it].push_back(*it);
        it = L[i].erase(it);
    }
}
 
 
int main()
{
    cin >> n ;
    for(int i=0; i<n; i++)
    {
        L[i].clear();
        L[i].push_back(i);
    }
    string str;
    while( cin >> str )
    {
        if( str == "quit" )
        {
            Print_L();
            break ;
        }
        else
        {
            string s;
            int a, b;
            cin >> a >> s >> b ;
            if( a == b ) continue ;//相等不行动
            int la, lb;
            iter pa = search(la, a);//找首次出现a的位置
            iter pb = search(lb,b);
            if( la == lb ) continue ;//两数是同一个手臂上的,不处理
            if( str == "move" )
            {
                if( s == "onto" )
                {
                    restore(la,pa);
                    restore(lb,pb);
                    L[lb].push_back(*pa);
                    L[la].erase(pa);
                }
                else if( s == "over")
                {
                    restore(la,pa);
                    L[lb].push_back(*pa);
                    L[la].erase(pa);
                }
            }
            else if( str == "pile" )
            {
                if( s == "onto" )
                {
                    restore(lb,pb);
                    while( pa!=L[la].end())
                    {
                        L[lb].push_back(*pa);
                        pa = L[la].erase(pa);
                    }
                }
                else if( s == "over" )
                {
                    while( pa != L[la].end())
                    {
                        L[lb].push_back(*pa);
                        pa = L[la].erase(pa);
                    }
                }
            }
        }
    }
 
    return 0;
}

 

posted @   Asimple  阅读(628)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示