ACM题目————Aggressive cows

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.
 
要把题目读懂!
 
二分枚举
代码:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#include <iostream>
#include <algorithm>
 
using namespace std;
const long long INF = 1000000002;
int a[100002], C, n;
 
bool OK(int m)
{
    int last = 0;
    for(int i=1; i<C; i++)
    {
        int cur = last + 1 ;
        while(cur<n && a[cur]-a[last]<m) cur ++ ;
        if(cur==n) return false ;
        last = cur ;
    }
    return true;
}
 
int main()
{
    cin >> n >> C ;
    for(int i=0; i<n; i++) cin >> a[i] ;
    sort(a,a+n);//排序
    int low = 0, high = a[n-1] + 1 ;
    while(high - low > 1)
    {
        int mid =  (low + high) >> 1 ;
        if(OK(mid)) low = mid ;
        else high = mid ;
    }
    cout << low << endl ;
 
    return 0;
}

 



posted @   Asimple  阅读(481)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 终于写完轮子一部分:tcp代理 了,记录一下
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
点击右上角即可分享
微信分享提示