Poj 2136 Vertical Histogram(打印垂直直方图)

一、Description

Write a program to read four lines of upper case (i.e., all CAPITAL LETTERS) text input (no more than 72 characters per line) from the input file and print a vertical histogram that shows how many times each letter (but not blanks, digits, or punctuation) appears in the all-upper-case input. Format your output exactly as shown.

Input

* Lines 1..4: Four lines of upper case text, no more than 72 characters per line.

Output

* Lines 1..??: Several lines with asterisks and spaces followed by one line with the upper-case alphabet separated by spaces. Do not print unneeded blanks at the end of any line. Do not print any leading blank lines.

Sample Input

THE QUICK BROWN FOX JUMPED OVER THE LAZY DOG.
THIS IS AN EXAMPLE TO TEST FOR YOUR
HISTOGRAM PROGRAM.
HELLO!

Sample Output

                            *
                            *
        *                   *
        *                   *     *   *
        *                   *     *   *
*       *     *             *     *   *
*       *     * *     * *   *     * * *
*       *   * * *     * *   * *   * * * *
*     * * * * * *     * * * * *   * * * *     * *
* * * * * * * * * * * * * * * * * * * * * * * * * *
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
二、题解

      目标:计算出给定的4行字符序列中每个字母出现的次数用“ * ”表示,并绘制出直方图。

      问题:1、计算字母出现的次数。 2、打印直方图

      方法:1、依次读入每一行到一个字符串,将26个字母依次和字符串中的字符比较,相符则加1.把结果存放到大小为26的数组a中。

                  2、找出a数组中的最大数max,将max循环递减,每次循环比较a数组和max,如果相等则输出“* ”,否则输出空格。每次比较完一个max,换行一次。最后输出A~Z即    可。

      注意:难点在于输出,刚开始的时候也没明白。后来一想也挺简单的。刚开始的时候就用SC.next()读入四个数组,结果怎么都不对,后来发现犯傻了。应该是读入一行才对,呵呵。这个老师不记得, BufferedReader br=new BufferedReader(new InputStreamReader(System.in));,提醒自己一下。

三、java代码

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

  public class Main {
	  static int[] a=new int [27];
	  static int max=-1;
	  public static void count(String s){
		  int i;
		  for(i=0;i<s.length();i++){
			  for(int k=65;k<=90;k++){
				  if((int)s.charAt(i)==k){
					  a[k-64]++;
				  }
				  if(a[k-64]>max)
					  max=a[k-64];
			  }
		 }
	 }
	  public static void main(String[] args) throws IOException  {
       BufferedReader br=new BufferedReader(new InputStreamReader(System.in));
       String[] s=new String[4];
       int i,j;
       char c;
       for(i=0;i<4;i++){
    	   s[i]=br.readLine();
    	   count(s[i]);
       }
       for(j=max;j>=1;j--){
			for(i=1;i<=26;i++){
				if(a[i]<j)
					System.out.print("  ");
				else
					System.out.print("* ");
			}
			System.out.println();
	   }	
       for(c='A';c<='Z';c++){
    	   System.out.print(c+" ");
       }
    }  
 }     
  
  

  













版权声明:本文为博主原创文章,未经博主允许不得转载。

posted @ 2013-08-04 19:15  InkGenius  阅读(272)  评论(0编辑  收藏  举报