[题解] poj 2585 Window Pains (拓扑排序)

- 传送门 -

 http://poj.org/problem?id=2585

#Window Pains

| Time Limit: 1000MS |   | Memory Limit: 65536K |
| Total Submissions: 2284 |   | Accepted: 1149 |

Description

Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux's windows would be represented by the following 2 x 2 windows:

| 1 | 1 | . | . |
| 1 | 1 | . | . |
| . | . | . | . |
| . | . | . | . |

| . | 2 | 2 | . |
| . | 2 | 2 | . |
| . | . | . | . |
| . | . | . | . |

| . | . | 3 | 3 |
| . | . | 3 | 3 |
| . | . | . | . |
| . | . | . | . |

| . | . | . | . |
| 4 | 4 | . | . |
| 4 | 4 | . | . |
| . | . | . | . |

| . | . | . | . |
| . | 5 | 5 | . |
| . | 5 | 5 | . |
| . | . | . | . |

| . | . | . | . |
| . | . | 6 | 6 |
| . | . | 6 | 6 |
| . | . | . | . |

| . | . | . | . |
| . | . | . | . |
| 7 | 7 | . | . |
| 7 | 7 | . | . |

| . | . | . | . |
| . | . | . | . |
| . | 8 | 8 | . |
| . | 8 | 8 | . |

| . | . | . | . |
| . | . | . | . |
| . | . | 9 | 9 |
| . | . | 9 | 9 |

When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window 1and then window 2 were brought to the foreground, the resulting representation would be:

| 1 | 2 | 2 | ? |
| 1 | 2 | 2 | ? |
| ? | ? | ? | ? |
| ? | ? | ? | ? |

| If window 4 were then brought to the foreground: |

| 1 | 2 | 2 | ? |
| 4 | 4 | 2 | ? |
| 4 | 4 | ? | ? |
| ? | ? | ? | ? |

. . . and so on . . . 
Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 3 components:

  1. Start line - A single line: 
    START

  2. Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux's screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space.

  3. End line - A single line: 
    END

After the last data set, there will be a single line: 
ENDOFINPUT

Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.

Output

For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux's screen, the output will be a single line with the statement:

THESE WINDOWS ARE CLEAN

Otherwise, the output will be a single line with the statement: 
THESE WINDOWS ARE BROKEN

Sample Input

START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT

Sample Output

THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN

Source

South Central USA 2003

- 题意 -

 对于一个 4X4 的矩阵. 1 - 9 都有自己的(4个)初始位置(如上图所示).
 当两个数字的位置重合时, 后来的数字可以显示出来.
 给定一个矩阵, 求是否有一个序列表示 9 的数字先来后到的顺序, 使得它们最后显示出来是给定矩阵的样子.
 

- 思路 -

 如果有 y 在 x 的初始位置上, 说明 y 比 x 后来, 从 x 向 y 连一条边, 若图中无环则成立, 否则不成立.
 
 细节见代码.
 

- 代码 -

#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;

const int N = 15;

int V[N][N], MAP[N][N], IN[N];
char S[N];
vector<int>Q;

void topo() {
	int ans = 0;
	for (int i = 1; i <= 9; ++i) {
		for (int j = 1; j <= 9; ++j) {
			if (IN[j] == 0) {
				ans ++;
				IN[j] --;
				for (int k = 1; k <= 9; ++k) {
					if (MAP[j][k])
						IN[k] --;
				}
				break;
			}
		}
	}
	if (ans == 9) printf("THESE WINDOWS ARE CLEAN\n");
	else printf("THESE WINDOWS ARE BROKEN\n");
}

int main() {
	while (~scanf("%s", S)) {
		if (S[0] == 'E') break;
		memset(MAP, 0, sizeof (MAP));
		memset(IN, 0, sizeof (IN));
		for (int i = 0; i < 4; ++i)
			for (int j = 0; j < 4; ++j)
				scanf("%d", &V[i][j]);
		for (int i = 1; i <= 9; ++i) {
			int x = (i - 1) / 3, y = (i - 1) % 3, q;
			for (int v1 = 0; v1 < 2; ++v1) {
				for (int v2 = 0; v2 < 2; ++v2) { // i 的四个初始位置
					q = V[x + v1][y + v2];
					if (q != i) {
						if (MAP[q][i] == 0)
							IN[i] ++;
						MAP[q][i] = 1;
					}
				}
			}
		}
		topo();
		scanf("%s", S);
	}
	return 0;
}
posted @ 2017-08-20 21:14  lstttt  阅读(158)  评论(0编辑  收藏  举报