[题解] poj 3259 Wormholes (dfs/bellmanford判负环)

- 传送门 -

 http://poj.org/problem?id=3259

#Wormholes

| Time Limit: 2000MS |   | Memory Limit: 65536K |
| Total Submissions: 54401 |   | Accepted: 20260 |

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself 😃 .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold

[[Submit](http://poj.org/submit?problem_id=3259)]   [[Status](http://poj.org/problemstatus?problem_id=3259)]   [[Discuss](http://poj.org/bbs?problem_id=3259)]

- 题意 -

 给定n个节点, m条无向边, w条有向边.
 无向边权值为正, 有向边权值为负.(输入中都为正, 有向边权值要取反)
 判断有没有负环.
 

- 思路 -

 把无向边改为两条有向边即可.
 
 之前在类似题目中用到了dfs和bfs, 但是上次用bfs很慢, 这次就没有用了.
 试了一下bellmanford, 跑得很快, 尤其可贵的是复杂度十分明确.\((O(nm+m))\)
 该算法过程如下:
 1. 进行n次松弛(对每条边, n为节点数).
 2. 扫一遍边, 若还有可松弛的边说明有负环, 否则没有.
 
  细节见代码.
 

- 代码 -

dfs

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

const int N = 500 + 5;
const int M = 5000 + 500;

int VIS[N], DIS[N];
int HD[N], NXT[M], TO[M], V[M];
int cas, n, m, w, sz;
bool flag;

void add(int frm, int to, int v) {
	TO[++sz] = to; V[sz] = v; NXT[sz] = HD[frm]; HD[frm] = sz;
}

void init() {
	sz = 0;
	flag = false;
	memset(HD, 0, sizeof (HD));
}

void spfa_dfs(int x) {
	VIS[x] = 1;
	for (int i = HD[x]; i; i = NXT[i]) {
		int v = TO[i];
		if (flag) break;
		if (DIS[v] > DIS[x] + V[i]) {
			if (VIS[v]) {
				flag = true;
				printf("YES\n");
				break;
			}
			DIS[v] = DIS[x] + V[i];
			spfa_dfs(v);
		}
	}
	VIS[x] = 0;
}

int main() {
	scanf("%d", &cas);
	for (int cass = 1; cass <= cas; ++ cass) {
		init();
		int x, y, v;
		scanf("%d%d%d", &n, &m, &w);
		for (int i = 1; i <= m; ++i) {
			scanf("%d%d%d", &x, &y, &v);
			add(x, y, v);
			add(y, x, v);
		}
		for (int i = 1; i <= w; ++i) {
			scanf("%d%d%d", &x, &y, &v);
			add(x, y, -v);
		}
		for (int i = 1; i <= n; ++i) {
			if (flag) break;
			memset(DIS, 0x3f, sizeof (DIS));
			DIS[x] = 0;
			spfa_dfs(i);
		}
		if (!flag) printf("NO\n");
	}
	return 0;
}

bellmanford

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

const int N = 500 + 5;
const int M = 5000 + 500;

int VIS[N], DIS[N];
int FRM[M], TO[M], V[M];
int cas, n, m, w, sz;
bool flag;

void add(int frm, int to, int v) {
	TO[++sz] = to; V[sz] = v; FRM[sz] = frm;
}

void init() {
	sz = 0;
	memset(DIS, 0x3f, sizeof (DIS));
}

int bellmanford(int x) {
	DIS[x] = 0;
	for (int i = 1; i <= n; ++i)
		for (int j = 1; j <= sz; ++j)
			if (DIS[TO[j]] > DIS[FRM[j]] + V[j])
				DIS[TO[j]] = DIS[FRM[j]] + V[j];
	for (int j = 1; j <= sz; ++j)
		if (DIS[TO[j]] > DIS[FRM[j]] + V[j])
			return 0;
	return 1;
}

int main() {
	scanf("%d", &cas);
	for (int cass = 1; cass <= cas; ++ cass) {
		init();
		int x, y, v;
		scanf("%d%d%d", &n, &m, &w);
		for (int i = 1; i <= m; ++i) {
			scanf("%d%d%d", &x, &y, &v);
			add(x, y, v);
			add(y, x, v);
		}
		for (int i = 1; i <= w; ++i) {
			scanf("%d%d%d", &x, &y, &v);
			add(x, y, -v);
		}
		int ans = bellmanford(1);
		if (ans) printf("NO\n");
		else printf("YES\n");
	}
	return 0;
}
posted @ 2017-08-18 11:19  lstttt  阅读(142)  评论(0编辑  收藏  举报