PAT_A1049 Counting Ones【困难】

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤230).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5
#include<bits/stdc++.h>
using namespace std;
int n, ans;
int main(){
	scanf("%d", &n);
	int r = 0, l = 0, a = 1, now;
	while(n/a != 0){
		l = n/(a*10);
		now = n/a%10;
		r = n%a;
		if(now == 0) ans += (l * a);
		else if(now == 1) ans += l * a + r + 1;
		else ans += (l+1) * a;
		a *= 10;
	}
	printf("%d\n", ans);
	return 0;
}

总结

数学问题/简单数学 需要严格推理,具体见算法笔记上机指南p199.

每次迭代,记录当前位出现1的个数;对当前位的数,分<1, ==1, >1三种情况讨论。

posted @   永无荒城  阅读(3)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· winform 绘制太阳,地球,月球 运作规律
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· AI与.NET技术实操系列(五):向量存储与相似性搜索在 .NET 中的实现
· 超详细:普通电脑也行Windows部署deepseek R1训练数据并当服务器共享给他人
点击右上角即可分享
微信分享提示