HDU 1028
Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6504 Accepted Submission(s): 4592
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The
input contains several test cases. Each test case contains a positive
integer N(1<=N<=120) which is mentioned above. The input is
terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
简单母函数 不解释
View Code
1 #include"iostream" 2 using namespace std; 3 int main() 4 { 5 int c1[125],c2[125]; 6 int i,j,k,n; 7 while(cin>>n) 8 { 9 for(i=0;i<121;i++) 10 { 11 c1[i]=1; 12 c2[i]=0; 13 } 14 for(i=2;i<=n;i++) 15 { 16 for(j=0;j<=n;j++) 17 for(k=0;k+j<=n;k+=i) 18 c2[k+j]+=c1[j]; 19 for(j=0;j<=n;j++) 20 { 21 c1[j]=c2[j]; 22 c2[j]=0; 23 } 24 } 25 cout<<c1[n]<<endl; 26 } 27 return 0; 28 }