HDU 1331

Function Run Fun

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1239    Accepted Submission(s): 631


Problem Description
We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
 

 

Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
 

 

Output
Print the value for w(a,b,c) for each triple.
 

 

Sample Input
1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1
 

 

Sample Output
w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1
 
第一次没有查有道~  太难得了!
 
这道也是水题啦~  一开始直接用递归   果断超时……
然后就是纠结   后来抱着试试看的心态  直接开数组过了  
这道题目特点就是  w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)  
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)
用的都是前面已经算出来的数据,所以直接把存数组里的数据拿来  不用再重复计算~
#include"iostream"
using namespace std;

int f[25][25][25];

void w(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)
    {
        f[a][b][c]=1;
    }
    else if(a<b&&b<c)
    {
        f[a][b][c]=f[a][b][c-1]+f[a][b-1][c-1]-f[a][b-1][c];
    }
    else
    {
        f[a][b][c]=f[a-1][b][c]+f[a-1][b-1][c]+f[a-1][b][c-1]-f[a-1][b-1][c-1];
    }
}

int main()
{
    int a,b,c;
    int i,j,k;
    for(i=0;i<21;i++)
        for(j=0;j<21;j++)
            for(k=0;k<21;k++)
                w(i,j,k);
    while(cin>>a>>b>>c)
    {
        if(a==-1&&b==-1&&c==-1)
            break;
        if(a<=0||b<=0||c<=0)
        {
            cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<1<<endl;
            continue;
        }
        else if(a>20||b>20||c>20)
        {
            cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<f[20][20][20]<<endl;
            continue;
        }
        cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<f[a][b][c]<<endl;
    }
    return 0;
}

 


posted on 2012-04-18 00:02  Action!  阅读(359)  评论(2编辑  收藏  举报

导航