Colorful Subsequence

题目描述

You are given a string S of length N. Among its subsequences, count the ones such that all characters are different, modulo 109+7. Two subsequences are considered different if their characters come from different positions in the string, even if they are the same as strings.

Here, a subsequence of a string is a concatenation of one or more characters from the string without changing the order.

Constraints
·1≤N≤100000
·S consists of lowercase English letters.
·|S|=N

输入

Input is given from Standard Input in the following format:

N
S

输出

Print the number of the subsequences such that all characters are different, modulo 109+7.

 

样例输入

4
abcd

样例输出

15

提示

Since all characters in S itself are different, all its subsequences satisfy the condition.

 代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll p=1e9+7;
ll n,a[100],ans=1;
string s;
int main() {
  cin >> n >> s;
  for (int i = 0; i < n; i++) {
    a[s[i] - 'a']++;
  }
  for (int i = 0; i < 26; i++) {
    ans = ans * (a[i] + 1) % p;
  }
  printf("%lld\n", ans-1);
}
posted @ 2019-07-15 14:22  Snow_in_winer  阅读(209)  评论(0编辑  收藏  举报