YunYan

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int N=1E3+7;
char arr1[N];
char arr2[N];
int  sum[N];
int main(){
    int t,k1=0;
    cin>>t;
    while(t--){
    
    
        k1++;
        memset(sum,0,sizeof(sum));
        scanf("%s",arr1);
        scanf("%s",arr2); 
        
        int len1=strlen(arr1);
        int len2=strlen(arr2);
        int k=0;
        int i,j;
        
        
        for(i=len1-1,j=len2-1;i>=0&&j>=0;i--,j--){
            int y=arr1[i]-'0'+arr2[j]-'0';
            if(y+sum[k]>=10){//注意这里是y+sum[k]判断是否 进位 
                sum[k+1]++;//进位的话就在 k+1 位置上累加一次 
                sum[k]+=y-10;
            }
            else {
                sum[k]+=y;
            }
            k++;
        }
        
        
        if(k<len1){
            for(int x=i;x>=0;x--){
                sum[k]+=arr1[x]-'0';
                k++;
            }
        }        
        else if(k<len2){
            for(int x=j;x>=0;x--){
                sum[k]+=arr2[x]-'0';
                k++;
            }
        }        
        else if(sum[k]!=0){//k这个位置可能会有残余 
            k++;
        }
        
        
        
        printf("Case %d:\n",k1);
        printf("%s + %s = ",arr1,arr2);
        for(int i=k-1;i>=0;i--)
            printf("%d",sum[i]); 
        cout<<endl;
        if(t>=1) cout<<endl;
        
        
        
    }
    
    return 0;
}

 

posted on 2019-08-19 15:46  Target--fly  阅读(225)  评论(0编辑  收藏  举报