YunYan

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

InputThe input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
OutputFor each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2
1 2
2 2
Sample Output
NO
YES

这是一道数学思维题目 总之就是a+b-_gcd(a,b);

复制代码
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ll n,m;
        scanf("%lld %lld",&n,&m);
        if(__gcd(n,m)==1)
            puts("NO");
        else puts("YES");
     } 
    return 0;
 } 
复制代码

 

posted on   Target--fly  阅读(191)  评论(0编辑  收藏  举报
努力加载评论中...
点击右上角即可分享
微信分享提示