hdu 1009 FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 67905    Accepted Submission(s): 23150


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

 

Sample Output
13.333 31.500
老鼠有m磅猫食,想和猫换食物,用j[i]食物可以换取H[i]食物,求可换取的最多食物
贪心可以了,H[i]/J[i]从大到小排序一遍  ,从大的那
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
typedef long long ll;
using namespace std;
struct node
{
    int x,y;
    double num;
}a[10000];
bool cmp(node xx,node yy){
    return xx.num>yy.num;
}
int main(){
    int m,n;
    int i,j;
    while(scanf("%d%d",&m,&n)!=EOF){
        if(m==-1&&n==-1)
            break;
        for(i=1;i<=n;i++){
            scanf("%d%d",&a[i].x,&a[i].y);
            a[i].num=(double)a[i].x/a[i].y;
        }
        sort(a+1,a+n+1,cmp);
        double sum=0;
        for(i=1;i<=n;i++){
            //cout<<a[i].num<<endl;
            if(a[i].y<=m)
            {
                sum=sum+a[i].x;
                m=m-a[i].y;
            }
            else{
                sum=sum+a[i].num*m;
                break;
            }
        }
        printf("%.3f\n",sum);
    }
}

 

posted on 2016-10-09 16:40  见字如面  阅读(134)  评论(0编辑  收藏  举报

导航