判断是否是完全二叉搜索树 + 一个段错误

真题训练3--2016年天梯赛决赛--补题                        

                        7-13 是否完全二叉搜索树 (30 分)

将一系列给定数字顺序插入一个初始为空的二叉搜索树(定义为左子树键值大,右子树键值小),你需要判断最后的树是否一棵完全二叉树,并且给出其层序遍历的结果。

输入格式:

输入第一行给出一个不超过20的正整数N;第二行给出N个互不相同的正整数,其间以空格分隔。

输出格式:

将输入的N个正整数顺序插入一个初始为空的二叉搜索树。在第一行中输出结果树的层序遍历结果,数字间以1个空格分隔,行的首尾不得有多余空格。第二行输出YES,如果该树是完全二叉树;否则输出NO

输入样例1:

9
38 45 42 24 58 30 67 12 51

输出样例1:

38 45 24 58 42 30 12 67 51
YES

输入样例2:

8
38 24 12 45 58 67 42 51

输出样例2:

38 45 24 58 42 12 67 51
NO


常规思路:(结构体创建树,在初始树t的时候,如果不令t=NULL,会段错误)

(7条消息) C语言指针段错误_sdkdlwk的博客-CSDN博客_指针段错误

#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>

using namespace std;

int n, a[100];
typedef struct tree{
    int val;
    struct tree *left, *right;
}TreeNode, *Tree;

void add(Tree &t, int val)
{
    if(t == NULL)   
    {
        Tree s = new TreeNode;
        s->val = val;
        s->left = s->right = NULL;
        t = s;
    }
    else
    {
        if(val > t->val)    add(t->left, val);
        else add(t->right, val);
    }
}

void levelPrint(Tree &t)
{
    if(t == NULL)   return ;
    
    vector<int> v;
    queue<Tree> q;
    
    q.push(t);
    while(q.size())
    {
        auto t = q.front();
        q.pop();
        v.push_back(t->val);
        if(t->left) q.push(t->left);
        if(t->right)    q.push(t->right);
    }
    
    for(int i = 0; i < v.size(); i ++ )
    {
        cout << v[i];
        if(i != v.size() - 1)   cout << " ";
    }
    cout << endl;
}

bool check(Tree &t)
{
    if(t == NULL)   return false;
    
    queue<Tree> q;
    q.push(t);
    while(q.size())
    {
        auto t = q.front();
        q.pop();
        if(t->left && t->right)
        {
            q.push(t->left);
            q.push(t->right);
        }
        else if(!t->left && t->right)   return false;
        else if(!t->right)
        {
            if(t->left) q.push(t->left);
            while(q.size())
            {
                t = q.front();
                if(!t->left && !t->right)   q.pop();
                else    return false;
            }
            return true;
        }
    }
    return true;
}

int main()
{ 
    Tree t = NULL;//如果仅仅是Tree t;会段错误
    cin >> n;
    for(int i = 0; i < n; i ++ )
    {
        int v;
        cin >> a[i];
    }
    for(int i = 0; i < n; i ++ )    add(t, a[i]);
    levelPrint(t);
    
    bool flag = check(t);
    if(flag)   cout << "YES" << endl;
    else    cout << "NO" << endl;
    return 0;
}

 在本题中,判断是否是完全二叉树还有一种更方便简洁的做法

bool judge(Tree node)
{
	queue<Tree>que;
	que.push(node);
	int num = 0;
	while ((node = que.front()) != nullptr)
	{
		que.push(node->left);
		que.push(node->right);
		que.pop();
		num++;
	}
	if (num == n)
		return true;
	return false;
}

思路二:数组模拟二叉树(AC)

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 30;

int n, a[N];

void add(int i, int val)
{
    if(a[i] == -1)
    {
        a[i] = val;
        return ;
    }
    if(val > a[i])  add(i * 2, val);
    else    add(i * 2 + 1, val);
}

int main()
{
    memset(a, -1, sizeof a);
    cin >> n;
    for (int i = 0; i < n; i ++ )
    {
        int e;
        cin >> e;
        add(1, e);
    }

    int c = 0, i = 1;
    while(c < n)
    {
        while(a[i] == -1)   i ++ ;
        if(c)   cout << " " << a[i];
        else    cout << a[i];
        i ++ , c ++ ;
    }
    //编号c的作用是遍历整个二叉树
    //i是找到二叉树最后一个节点的编号
    //因为二叉完全树是一层一层,每层从左到右排列的
    //所以数组最后一个节点下标一定是n
    //这里我们遍历到n+1时结束
    cout << endl << (i == n + 1 ? "YES" : "NO");
    return 0;
}

posted @ 2022-05-05 08:41  光風霽月  阅读(12)  评论(0编辑  收藏  举报