POJ 1655 Balancing Act

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10229   Accepted: 4221

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

题解:求树的重心,和删除重心后得到的最大子树的结点数。树的重心就是在这棵树上找一个结点,使得删除这个结点后形成的森林的结点个数尽量平衡(也就是说最大的子树的借点数最小)。方法:DFS
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 20000 + 10

using namespace std;

int n, u, v;
struct node1{ int v, next; } E[MAX_N << 1];
struct node2{ int sum, cnt; } N[MAX_N];

int head[MAX_N], top = 0;
void add(int u, int v){ E[++ top].v = v; E[top].next = head[u]; head[u] = top; }
int DFS(int x, int last){
    N[x].sum = 1; N[x].cnt = 0;
    for(int i = head[x]; i; i = E[i].next){
        if(E[i].v != last){
            int t = DFS(E[i].v, x);
            N[x].sum += t; N[x].cnt = max(N[x].cnt, t);
        }
    }
    return N[x].sum;
}
int main(){
    int T; scanf("%d", &T);
    while(T --){
        top = 0; memset(head, 0, sizeof(head));
        scanf("%d", &n);
        REP(i, 1, n - 1){
            scanf("%d%d", &u, &v);
            add(u, v); add(v, u);
        }
        DFS(1, 0);
        int ans = 99999999, num = 0;
        REP(i, 1, n){
            N[i].cnt = max(N[i].cnt, n - N[i].sum);
            if(ans > N[i].cnt){
                ans = N[i].cnt; num = i;
            }
        }
        printf("%d %d\n", num, ans);
    }
    return 0;
}
         

 

 
posted @ 2015-06-10 11:26  ALXPCUN  阅读(144)  评论(0编辑  收藏  举报