Anniversary party

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4995   Accepted: 2824

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

树形DP:
先建图,注意后面的点才是父亲,根不一定是1。
设F[x][1]表示第x个人来聚会的最大欢乐值,F[x][0]表示他不来的欢乐值,所以就可以写出转移方程:
  F[x][1] += F[son(x)][0];
  F[x][0] += max(F[som(x)][1], F[son(x)][0]);
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define max(a, b) a > b ? a : b
#define MAX_N 6000 + 10

using namespace std;

int n, u, v, R;
int F[MAX_N][2];
struct node{
    int v, next;
}E[MAX_N << 1];

int head[MAX_N], top = 0;

void add(int u, int v){ E[++ top].v = v; E[top].next = head[u]; head[u] = top;}
void Gao(int x){
    for(int i = head[x]; i; i = E[i].next){
        Gao(E[i].v);
        F[x][1] += F[E[i].v][0];
        F[x][0] += max(F[E[i].v][1], F[E[i].v][0]);
    }
}
int main(){
    scanf("%d", &n);
    REP(i, 1, n) scanf("%d", &F[i][1]);
    bool ok[MAX_N];
    memset(ok, 0, sizeof(ok));
    while(scanf("%d%d", &u, &v) != EOF){
        if(u == 0 && v == 0) break;
        ok[u] = 1; add(v, u);
    }
    
    REP(i, 1, n) if(!ok[i]) { R = i; break; }
    Gao(R);
    printf("%d\n", max(F[R][1], F[R][0]));
    return 0;
}
    

 



posted @ 2015-06-10 08:11  ALXPCUN  阅读(170)  评论(0编辑  收藏  举报