POJ 3660 Cow Contest

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7739   Accepted: 4324

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

传递闭包
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 100 + 10

using namespace std;

int n, m, u, v;
bool map[MAX_N][MAX_N];

int main(){
    scanf("%d%d", &n, &m);
    memset(map, 0, sizeof(map));
    REP(i, 1, m){
        scanf("%d%d", &u, &v);
        map[u][v] = 1;
    }
    
    REP(k, 1, n) REP(i, 1, n) REP(j, 1, n){
        map[i][j] = map[i][j] | (map[i][k] & map[k][j]);
    }
    
    int ans = 0;
    REP(i, 1, n){
        int a = 0, b = 0;
        REP(j, 1, n) if(i != j && map[i][j]) a ++;
        REP(j, 1, n) if(i != j && map[j][i]) b ++;
        if(a + b == n - 1) ans ++;
    }
    
    printf("%d\n", ans);
    return 0;
} 

 


posted @ 2015-06-03 10:37  ALXPCUN  阅读(155)  评论(0编辑  收藏  举报