POJ 2608 Soundex

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9478   Accepted: 4710

Description

Soundex coding groups together words that appear to sound alike based on their spelling. For example, "can" and "khawn", "con" and "gone" would be equivalent under Soundex coding.
Soundex coding involves translating each word into a series of digits in which each digit represents a letter:
      1 represents B, F, P, or V

2 represents C, G, J, K, Q, S, X, or Z
3 represents D or T
4 represents L
5 represents M or N
6 represents R

The letters A, E, I, O, U, H, W, and Y are not represented in Soundex coding, and repeated letters with the same code digit are represented by a single instance of that digit. Words with the same Soundex coding are considered equivalent.

Input

Each line of input contains a single word, all upper case, less than 20 letters long.

Output

For each line of input, produce a line of output giving the Soundex code.

Sample Input

KHAWN
PFISTER
BOBBY

Sample Output

25
1236
11

CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 20 + 10

using namespace std;

int main(){
    char s[MAX_N];
    int score[27] = {0, 0, 1, 2, 3, 0, 1, 2, 0, 0, 2, 2, 4, 5, 5, 0, 1, 2, 6, 2, 3, 0, 1, 0, 2, 0, 2};
    while(scanf("%s", s + 1) != EOF){
        int a[MAX_N], num = 0; memset(a, 9999999, sizeof(a));
        REP(i, 1, strlen(s + 1)){
            if(score[(int)(s[i] - 'A' + 1)] != 0 && score[(int)(s[i - 1] - 'A' + 1)] != score[(int)(s[i] - 'A' + 1)]) 
                a[++ num] = score[(int)(s[i] - 'A' + 1)];
        }
        REP(i, 1, num) cout << a[i]; cout << endl;
    }
    return 0;
}

 


posted @ 2015-06-01 13:27  ALXPCUN  阅读(148)  评论(0编辑  收藏  举报