POJ 1988 Cube Stacking

Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 20776   Accepted: 7278
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

银河英雄传说。。
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 30000 + 100
using namespace std;
int F[MAX_N], D[MAX_N], S[MAX_N];
void find(int x){
    if(F[x] != x){
        find(F[x]); D[x] += D[F[x]]; F[x] = F[F[x]];
    }
}
void Union(int x,int y){
    find(x); find(y);
    x = F[x]; y = F[y];
    F[x] = y; D[x] = S[y]; S[y] += S[x];
}
int main(){
    REP(i, 1, MAX_N) F[i] = i, D[i] = 0, S[i] = 1;
    int T, a, b; char c;
    scanf("%d", &T);
    while(T --){
        scanf("\n%c", &c);
        if(c == 'M') scanf("%d%d", &a, &b), Union(a, b);
        else scanf("%d", &a), find(a), printf("%d\n", D[a]);
    } 
    return 0;
}

 


posted @ 2015-05-27 07:33  ALXPCUN  阅读(114)  评论(0编辑  收藏  举报