POJ 2488 A Knight's Journey

ime Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 34320   Accepted: 11688

Description

Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题解:DFS
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 25

using namespace std;

int n, p, q, sum;
bool vis[MAX_N][MAX_N], output;
char pth[MAX_N * 2];
int dis_x[8] = {-2, -2, -1, -1, 1, 1, 2, 2};
int dis_y[8] = {-1, 1, -2, 2, -2, 2, -1, 1};

void dfs(int dep, int x, int y){
    if (dep == sum){
        REP(i, 0, 2 * dep - 1)
            printf("%c", pth[i]);
        printf("\n\n");
        output = true;
        return;
    }
    
    for (int i = 0; i < 8 && output == false; i ++){
        int new_x = x + dis_x[i], new_y = y + dis_y[i];
        if (new_x > 0 && new_x <= q && new_y > 0 && new_y <= p && vis[new_x][new_y] == false){
            vis[new_x][new_y] = true;            
            pth[dep * 2] = 'A' + new_x - 1;
            pth[dep * 2 + 1] = '1' + new_y - 1;
            dfs(dep + 1, new_x, new_y);
            vis[new_x][new_y] = false; 
        }
    }
}

int main(){
    int tmp = 0;
    scanf("%d", &n);
    for (int i = 1; i <= n; i ++){
        scanf("%d%d", &p, &q);
        printf("Scenario #%d:\n", ++tmp);
        REP(i, 1, p) REP(j, 1, q) vis[i][j] = false;
        vis[1][1] = true;
            sum = p * q; output = false;
        pth[0] = 'A'; pth[1] = '1';
        dfs(1, 1, 1);
        if (output == false) printf("impossible\n\n");
    }
    return 0;
}

 


posted @ 2015-05-25 10:56  ALXPCUN  阅读(133)  评论(0编辑  收藏  举报