POJ 1163

The Triangle

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 40041   Accepted: 24119

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 100 + 10

using namespace std;

int main(){
    int a[MAX_N][MAX_N], n, F[MAX_N][MAX_N];
    scanf("%d", &n);
    REP(i, 1, n) REP(j, 1, i) scanf("%d", &a[i][j]);
    
    memset(F, 0, sizeof(F));
    REP(i, 1, n) REP(j, 1, i){
        F[i][j] = max(F[i - 1][j] + a[i][j], F[i - 1][j - 1] + a[i][j]);
    }
    
    int ans = 0;
    REP(i, 1, n) ans = max(ans, F[n][i]);
    printf("%d\n", ans);
    return 0;
}
    

 

 
posted @ 2015-05-22 07:42  ALXPCUN  阅读(123)  评论(0编辑  收藏  举报