POJ 1552

Doubles

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 19905   Accepted: 11516

Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input

The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output

The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output

3
2
0

CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 20

using namespace std;

int a[MAX_N];
bool check[MAX_N << 1];

int main(){
    while(scanf("%d", &a[1])){
        if(a[1] == -1) break;
        memset(check, false, sizeof(check));
        check[a[1]] = 1;
        int tmp, num = 1;
        while(scanf("%d", &tmp)){
            if(tmp == 0) break; a[++num] = tmp, check[tmp] = 1;
        }
    //    REP(i, 1, num) printf("%d ", a[i]); cout << endl << endl;
        int ans = 0;
        REP(i, 1, num) if(a[i] % 2 == 0 && check[a[i] / 2]) ans ++;
        printf("%d\n", ans); 
    }
}
    
        

 

 
posted @ 2015-05-21 14:51  ALXPCUN  阅读(148)  评论(0编辑  收藏  举报