POJ2251-Dungeon Master

 

题目链接:点击打开链接

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

大意:3维的迷宫。从S起点到E终点的最短时间。如果不能到达,就输出那句话。

 

 

思路:涉及最短步数一般都是BFS,注意细节就行了。

 

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<map>
#include<vector>
#include<string>
#include<set>
#include<queue>
using namespace std;
const int MAX = 40;

char G[MAX][MAX][MAX];
int vis[MAX][MAX][MAX];

int l, n, m, flag;

struct node{
    int x;
    int y;
    int z;
    int loyer;
}Node, S, E, temp;//Node topnode S E temp可以设置这些变量

int dir[6][3] = {0, -1, 0, 0, 1, 0, 1, 0, 0, -1, 0, 0, 0, 0, -1, 0, 0, 1};//6个方向

bool judge(int x, int y, int z) {//判断这个点
    if(x < 0 || x >= n || y < 0 || y >= m || z < 0 || z >= l)//出界(注意是>= <=)
        return false;
    if(vis[x][y][z] || G[x][y][z] == '#')
        return false;
    return true;
}

int bfs(int x, int y, int z) {//bfs找终点
    queue<node> q;
    Node.x = x;
    Node.y = y;
    Node.z = z;
    Node.loyer = 0;
    q.push(Node);//压起点
    vis[x][y][z] = 1;//标记
    while(!q.empty()) {
        node topnode = q.front();//取出一个
        q.pop();//记得删除
        temp.loyer = topnode.loyer + 1;//先加步数
        for(int i = 0; i < 6; i++) {//6个方向访问
            temp.x = topnode.x + dir[i][0];
            temp.y = topnode.y + dir[i][1];
            temp.z = topnode.z + dir[i][2];
            if(judge(temp.x, temp.y, temp.z)) {//是否到终点
                if(G[temp.x][temp.y][temp.z] == 'E')
                    return temp.loyer;//返回步数
                q.push(temp);
                vis[temp.x][temp.y][temp.z] = 1;//标记
            }
        }
    }
    return -1;
}

int main() {
    while(~scanf("%d %d %d", &l, &n, &m)) {
        if(l == 0 && n == 0 && m == 0)
            break;
        memset(vis, 0, sizeof(vis));
        for(int k = 0; k < l; k++) {
            for(int i = 0; i < n; i++) {
                for(int j = 0; j < m; j++) {
                    cin >> G[i][j][k];//不要用scanf了。难受
                    if(G[i][j][k] == 'S') {
                        S.x = i;
                        S.y = j;
                        S.z = k;
                    }
                }
            }
        }
        flag = bfs(S.x, S.y, S.z);
        if(flag != -1)
            printf("Escaped in %d minute(s).\n", flag);
        else
            printf("Trapped!\n");
    }
}

 

posted @ 2018-04-26 10:53  Frontierone  阅读(80)  评论(0编辑  收藏  举报