859. Kruskal算法求最小生成树
859. Kruskal算法求最小生成树 - AcWing题库
给定一个 n 个点 m 条边的无向图,图中可能存在重边和自环,边权可能为负数。
求最小生成树的树边权重之和,如果最小生成树不存在则输出 impossible
。
给定一张边带权的无向图 G=(V,E),其中 V 表示图中点的集合,E 表示图中边的集合,n=|V|,m=|E|。
由 V 中的全部 n 个顶点和 E 中 n−1 条边构成的无向连通子图被称为 G 的一棵生成树,其中边的权值之和最小的生成树被称为无向图 G 的最小生成树。
输入格式
第一行包含两个整数 n 和 m。
接下来 m行,每行包含三个整数 u,v,w,表示点 u 和点 v 之间存在一条权值为 w 的边。
输出格式
共一行,若存在最小生成树,则输出一个整数,表示最小生成树的树边权重之和,如果最小生成树不存在则输出 impossible
。
数据范围
1≤n≤105
1≤m≤2∗105
图中涉及边的边权的绝对值均不超过 10001000。
输入样例:
4 5
1 2 1
1 3 2
1 4 3
2 3 2
3 4 4
输出样例:
6
解析:
Kruskal算法流程如下:
1.建立并查集
2.把所有边按边的权值从大到小排序,扫描每条边
3.若此边的的两个端点在同一集合中,则忽略此边
4.否则合并这两个端点
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<math.h>
#include<map>
using namespace std;
typedef long long LL;
const int N = 2e5 + 5;
int n, m;
struct edge {
int a, b, w;
}edge[N];
int f[N];
int cmp(const struct edge& a, const struct edge& b) {
return a.w < b.w;
}
int find(int x) {
if (f[x] == x)
return x;
return f[x] = find(f[x]);
}
int main() {
scanf("%d%d", &n, &m);
for (int i = 1; i <= m; i++) {
scanf("%d%d%d", &edge[i].a, &edge[i].b, &edge[i].w);
}
sort(edge + 1, edge + 1 + m, cmp);
for (int i = 1; i <= n; i++)
f[i] = i;
int ans = 0, x, y, cnt = 0;
for (int i = 1; i <= m; i++) {
x = find(edge[i].a);
y = find(edge[i].b);
if (x != y) {
f[x] = y;
ans += edge[i].w;
cnt++;
}
}
if (cnt < n - 1)
cout << "impossible" << endl;
else
cout << ans << endl;
return 0;
}