838. 堆排序, 839. 模拟堆
完全二叉树手写小根堆
堆排序的五大功能
1.插入一个数
2.求集合当中的最小值
3.删除最小值
4.删除任意一个元素
5.修改任意一个元素
(最后两个功能stl中的堆即优先队列都没法直接实现)
838. 堆排序
输入一个长度为 n 的整数数列,从小到大输出前 m 小的数。
输入格式
第一行包含整数 n 和 m。
第二行包含 n 个整数,表示整数数列。
输出格式
共一行,包含 m 个整数,表示整数数列中前 m 小的数。
数据范围
1≤m≤n≤105,
1≤数列中元素≤109
输入样例:
5 3
4 5 1 3 2
输出样例:
1 2 3
解析:
此代码的第一次排序时间复杂的为 O(n)
#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<math.h>
#include<map>
using namespace std;
typedef long long LL;
const int N = 1e5 + 5, M = 3e5 + 5;
int n, m;
int h[N],cnt;
void down(int u) {
int t = u;
if (u * 2 <= cnt && h[2 * u] < h[t])t = 2 * u;
if (2 * u + 1 <= cnt && h[2 * u + 1] < h[t])t = 2 * u + 1;
if (u != t) {
swap(h[t], h[u]);
down(t);
}
}
int main() {
cin >> n >> m;
for (int i = 1; i <= n; i++)scanf("%d", &h[i]);
cnt = n;
for (int i = n / 2; i; i--)down(i);//时间复杂度为 O(n)
while (m--) {
printf("%d ", h[1]);
h[1] = h[cnt];
cnt--;
down(1);
}
return 0;
}
839. 模拟堆
维护一个集合,初始时集合为空,支持如下几种操作:
I x
,插入一个数 x;PM
,输出当前集合中的最小值;DM
,删除当前集合中的最小值(数据保证此时的最小值唯一);D k
,删除第 k 个插入的数;C k x
,修改第 k 个插入的数,将其变为 x;
现在要进行 N 次操作,对于所有第 22 个操作,输出当前集合的最小值。
输入格式
第一行包含整数 N。
接下来 N 行,每行包含一个操作指令,操作指令为 I x
,PM
,DM
,D k
或 C k x
中的一种。
输出格式
对于每个输出指令 PM
,输出一个结果,表示当前集合中的最小值。
每个结果占一行。
数据范围
1≤N≤105
−109≤x≤109
数据保证合法。
输入样例:
8
I -10
PM
I -10
D 1
C 2 8
I 6
PM
DM
输出样例:
-10
6
解析:
#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<math.h>
#include<map>
using namespace std;
typedef long long LL;
const int N = 1e5 + 5, M = 3e5 + 5;
int n,m;
int h[N], hp[N], ph[N], cnt;
void heapswap(int a, int b) {
swap(hp[ph[a]], hp[ph[b]]);
swap(ph[a], ph[b]);
swap(h[a], h[b]);
}
void down(int u) {
int t = u;
if (2 * u <= cnt && h[2 * u] < h[t]) t = 2 * u;
if (2 * u + 1 <= cnt && h[2 * u + 1] < h[t])t = 2 * u + 1;
if (u != t) {
heapswap(u, t);
down(t);
}
}
void up(int u) {
while (u / 2 != 0 && h[u] < h[u / 2]) {
heapswap(u, u / 2);
u /= 2;
}
}
int main() {
scanf("%d", &n);
char op[10];
int x;
while (n--) {
scanf("%s", op);
if (!strcmp("I", op)) {
scanf("%d", &x);
cnt++;
m++;
hp[m] = cnt, ph[cnt] = m;
h[cnt] = x;
up(cnt);
}
else if (!strcmp("PM", op)) {
printf("%d\n", h[1]);
}
else if (!strcmp("DM", op)) {
heapswap(1, cnt);
cnt--;
down(1);
}
else if (!strcmp("D", op)) {
scanf("%d", &x);
int k = hp[x];
heapswap(k, cnt);
cnt--;
up(k);
down(k);
}
else {
int k;
scanf("%d%d", &k, &x);
h[hp[k]] = x;
up(hp[k]);
down(hp[k]);
}
}
return 0;
}