828. 模拟栈 , 数组模拟栈

828. 模拟栈 - AcWing题库

实现一个栈,栈初始为空,支持四种操作:

  1. push x – 向栈顶插入一个数 x;
  2. pop – 从栈顶弹出一个数;
  3. empty – 判断栈是否为空;
  4. query – 查询栈顶元素。

现在要对栈进行 M 个操作,其中的每个操作 33 和操作 44 都要输出相应的结果。

输入格式

第一行包含整数 M,表示操作次数。

接下来 M 行,每行包含一个操作命令,操作命令为 push xpopemptyquery 中的一种。

输出格式

对于每个 empty 和 query 操作都要输出一个查询结果,每个结果占一行。

其中,empty 操作的查询结果为 YES 或 NOquery 操作的查询结果为一个整数,表示栈顶元素的值。

数据范围

1≤M≤100000,
1≤x≤109
所有操作保证合法。

输入样例:
10
push 5
query
push 6
pop
query
pop
empty
push 4
query
empty
输出样例:
5
5
YES
4
NO

 代码

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<math.h>
#include<map>
#include<unordered_map>
using namespace std;
typedef long long LL;
const int N = 1e5 + 5, M = 3e5 + 5; 
int n;
int stk[N], tt;

int main() {
	cin >> n;
	char op[20];
	int x;
	for (int i = 1; i <= n; i++) {
		scanf("%s", op);
		if (!strcmp(op, "push")) {
			scanf("%d", &x);
			stk[++tt] = x;
		}
		else if (!strcmp("pop", op)) {
			if(tt>0)tt--;
		}
		else if (!strcmp("empty", op)) {
			if (tt == 0)printf("YES\n");
			else printf("NO\n");
		}
		else if (!strcmp("query", op)) {
			if(tt!=0)
			printf("%d\n", stk[tt]);
		}
	}
	return 0;
}

posted @ 2023-10-30 23:51  Landnig_on_Mars  阅读(2)  评论(0编辑  收藏  举报  来源