hud 3507,Print Article,斜率优化dp

Problem - 3507 (hdu.edu.cn)

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 26705    Accepted Submission(s): 8024


 

Problem Description
Zero has an old printer that doesn't work well sometimes. As it is antique, he still like to use it to print articles. But it is too old to work for a long time and it will certainly wear and tear, so Zero use a cost to evaluate this degree.
One day Zero want to print an article which has N words, and each word i has a cost Ci to be printed. Also, Zero know that print k words in one line will cost


M is a const number.
Now Zero want to know the minimum cost in order to arrange the article perfectly.
 

Input
There are many test cases. For each test case, There are two numbers N and M in the first line (0 ≤ n ≤ 500000, 0 ≤ M ≤ 1000). Then, there are N numbers in the next 2 to N + 1 lines. Input are terminated by EOF.
 

Output
A single number, meaning the mininum cost to print the article.
 

Sample Input
 
 
5 5
5
9
5
7
5
 

Sample Output
 
 
230
 

Author
Xnozero
 

Source

 解析:斜率优化dp

HDU3507 Print Article —— 斜率优化DP - h_z_cong - 博客园 (cnblogs.com)

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<math.h>
#include<map>

using namespace std;
typedef long long LL;
const int N = 5e5 + 5;
int n, m;
LL c[N], f[N],q[N];

LL getup(int j, int k) {
	return f[j] + c[j] * c[j] - (f[k] + c[k] * c[k]);
}

LL getdown(int j, int k) {
	return 2 * (c[j] - c[k]);
}

int main() {
	while (scanf("%d%d", &n, &m) != EOF) {
		for (int i = 1; i <= n; i++) {
			scanf("%d", &c[i]);
			c[i] += c[i - 1];
		}
		f[0] = 0;
		int hh = 0, tt = 0;
		q[0] = 0;
		for (int i = 1; i <= n; i++) {
			while (hh < tt && getup(q[hh + 1], q[hh]) < getdown(q[hh + 1],q[ hh]) * c[i])hh++;
			int j = q[hh];
			f[i] = f[j] + (c[i] - c[j]) * (c[i] - c[j]) + m;
			while (hh < tt && getup(i, q[tt]) * getdown(q[tt], q[tt - 1]) <= getup(q[tt], q[tt - 1]) * getdown(i, q[tt]))tt--;
			q[++tt] = i;
		}
		printf("%d\n", f[n]);
	}
	return 0;
}

 

posted @ 2023-11-27 15:54  Landnig_on_Mars  阅读(5)  评论(0编辑  收藏  举报  来源