POJ1651 Multiplication Puzzle(区间DP)

Multiplication Puzzle

 

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7050Accepted: 4339

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6 10 1 50 50 20 5 

Sample Output

3650

Source

Northeastern Europe 2001, Far-Eastern Subregion

 

题意:给出一组N个数,每次从中抽出一个数(第一和最后一个不能抽),该次的得分即为抽出的数与相邻两个数的乘积。直到只剩下首尾两个数为止。问最小得分是多少? 

思路在代码里了

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define INF 1000000000
const int N = 110;
int dp[N][N];
int a[N];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0; i<n ;i++)
    {
        scanf("%d",&a[i]);
    }
    for(int i=0; i+2<n; i++)
    {
        dp[i][i+2] = a[i]*a[i+1]*a[i+2];
    }
    for(int i=n; i>=0; i--)
    {
        for(int j=i+3; j<n; j++)
        {
            dp[i][j] = INF;
            for(int k=i+1; k<j; k++)
            {
                //dp[i][j]表示把第i个数字到第j个数字之间(不包括i,j)的数字去光后得到的最小值,假设k是i和j之间最后取出的那张卡片
                dp[i][j] = min(dp[i][j],dp[i][k]+dp[k][j]+a[i]*a[j]*a[k]);
            }
        }
    }
    printf("%d\n",dp[0][n-1]);
    return 0;
}
View Code
posted @ 2015-07-27 13:33  Doli  阅读(89)  评论(0编辑  收藏  举报