POJ 1141 Brackets Sequence(区间DP)
Brackets Sequence
Time Limit: 1000MS | Memory Limit: 65536K | |||
Total Submissions: 27286 | Accepted: 7727 | Special Judge |
Description
Let us define a regular brackets sequence in the following way:
1. Empty sequence is a regular sequence.
2. If S is a regular sequence, then (S) and [S] are both regular sequences.
3. If A and B are regular sequences, then AB is a regular sequence.
For example, all of the following sequences of characters are regular brackets sequences:
(), [], (()), ([]), ()[], ()[()]
And all of the following character sequences are not:
(, [, ), )(, ([)], ([(]
Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.
1. Empty sequence is a regular sequence.
2. If S is a regular sequence, then (S) and [S] are both regular sequences.
3. If A and B are regular sequences, then AB is a regular sequence.
For example, all of the following sequences of characters are regular brackets sequences:
(), [], (()), ([]), ()[], ()[()]
And all of the following character sequences are not:
(, [, ), )(, ([)], ([(]
Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.
Input
The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.
Output
Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.
Sample Input
([(]
Sample Output
()[()]
Source
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define INF 1000000000
const int N = 110;
int dp[N][N],path[N][N];
char s[N];
void print(int i,int j)
{
if(i>j)return;
if(i==j)
{
if(s[i]=='['||s[i]==']')
printf("[]");
else
printf("()");
}
else if(path[i][j] == -1)
{
printf("%c",s[i]);
print(i+1,j-1);
printf("%c",s[j]);
}
else
{
print(i,path[i][j]);
print(path[i][j]+1,j);
}
}
int main()
{
while(gets(s))
{
int len = strlen(s);
if(len == 0)
{
printf("\n");
continue;
}
memset(dp,0,sizeof(dp));
for(int i=0; i<len; i++)
dp[i][i] = 1;
for(int i=len-1; i>=0; i--)
for(int j=i+1; j<len; j++)
{
dp[i][j]=INF;
if((s[i]=='['&&s[j]==']')||(s[i]=='('&&s[j]==')'))
{
if(dp[i][j]>dp[i+1][j-1])
{
dp[i][j] = dp[i+1][j-1];
path[i][j] = -1;
}
}
for(int k = i; k<j; k++)
{
if(dp[i][j]>dp[i][k]+dp[k+1][j])
{
dp[i][j] = dp[i][k]+dp[k+1][j];
path[i][j] = k;
}
}
}
print(0,len-1);
printf("\n");
}
return 0;
}
#include<cstdio>
#include<cstring>
using namespace std;
#define INF 1000000000
const int N = 110;
int dp[N][N],path[N][N];
char s[N];
void print(int i,int j)
{
if(i>j)return;
if(i==j)
{
if(s[i]=='['||s[i]==']')
printf("[]");
else
printf("()");
}
else if(path[i][j] == -1)
{
printf("%c",s[i]);
print(i+1,j-1);
printf("%c",s[j]);
}
else
{
print(i,path[i][j]);
print(path[i][j]+1,j);
}
}
int main()
{
while(gets(s))
{
int len = strlen(s);
if(len == 0)
{
printf("\n");
continue;
}
memset(dp,0,sizeof(dp));
for(int i=0; i<len; i++)
dp[i][i] = 1;
for(int i=len-1; i>=0; i--)
for(int j=i+1; j<len; j++)
{
dp[i][j]=INF;
if((s[i]=='['&&s[j]==']')||(s[i]=='('&&s[j]==')'))
{
if(dp[i][j]>dp[i+1][j-1])
{
dp[i][j] = dp[i+1][j-1];
path[i][j] = -1;
}
}
for(int k = i; k<j; k++)
{
if(dp[i][j]>dp[i][k]+dp[k+1][j])
{
dp[i][j] = dp[i][k]+dp[k+1][j];
path[i][j] = k;
}
}
}
print(0,len-1);
printf("\n");
}
return 0;
}