Fork me on GitHub

hdu 3665 Seaside floyd+超级汇点

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3665

题意分析:以0为起点,求到Sea的最短路径。 所以可以N为超级汇点,使用floyd求0到N的最短路径。

/*Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1151    Accepted Submission(s): 839


Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that the distance between the i-th town and the SMi town is LMi.
 

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

Sample Input
5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1
 

Sample Output
2
 

Source
2010 Asia Regional Harbin
 
*/
//floyd: d[i][j] = min(d[i][j], d[i][k]+d[k][j])
#include <cstdio>
#include <iostream>
using namespace std;
const int maxn = 100 + 10;
#define INF 1000001
int m[maxn], p[maxn], d[maxn][maxn];

void init()
{
    for(int i = 0; i < maxn; i++)
        for(int j = 0; j < maxn; j++)
            if(i == j) d[i][j] = 0;
            else d[i][j] = INF;
}

int main()
{
    int n, s, l;
    while(~scanf("%d", &n)){
        init();
        for(int i = 0; i < n; i++){
            scanf("%d%d", &m[i], &p[i]);
            if(p[i]) d[i][n] = 0;
            for(int j = 0; j < m[i];j++){
            scanf("%d%d", &s, &l);
            d[s][i] = d[i][s] = l;
            }
        }
        for(int k = 0; k <= n; k++)
            for(int i = 0; i <= n; i++)
                for(int j = 0; j <= n; j++)
                    d[i][j] = min(d[i][j], d[i][k]+d[k][j]);
        printf("%d\n", d[0][n]);
    }
    return 0;
}

 

posted @ 2015-02-25 11:19  I'm coding  阅读(211)  评论(0编辑  收藏  举报