Fork me on GitHub

hdu 1879 继续畅通工程

/************************************************************************/
/* hdu 1879
继续畅通工程


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6017    Accepted Submission(s): 2493




Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。




Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。


当N为0时输入结束。




Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。




Sample Input
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0




Sample Output
3
1
0




Author
ZJU




Source
浙大计算机研究生复试上机考试-2008年
*/
/************************************************************************/
//最小生成树
#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 5000 + 50;
int u[maxn], v[maxn], w[maxn], b[maxn], p[maxn], r[maxn], n, m;
void init()
{
    memset(u, 0, sizeof(u)); memset(v, 0, sizeof(v)); memset(w, 0, sizeof(w));
    memset(b, 0, sizeof(b)); memset(p, 0, sizeof(p)); memset(r, 0, sizeof(r));
} 

int cmp(const int i, const int j)
{
    return w[i] < w[j];
}

int find(int x)
{
    return p[x] == x ? x : p[x] = find(p[x]);
}

int Kruscal()
{
    int ans = 0;
    for(int i = 0; i < n; i++) p[i] = i;
    for(int i = 0; i < m; i++) r[i] = i;
    sort(r, r+m, cmp); 
    for(int i = 0; i < m; i++){
        int e = r[i];
        int x = find(u[e]), y = find(v[e]);
        if(x != y) {
            ans += w[e];
            p[x] = y; //合并
        }
    }
    return ans;
}

int main()
{
    while(~scanf("%d", &n) && n){
        init();
        m = n*(n-1)/2;
        for(int i = 0; i < m; i++){
            scanf("%d%d%d%d", &u[i], &v[i], &w[i], &b[i]);
            if(b[i] == 1) w[i] = 0;
        }
        int cnt = Kruscal();
        printf("%d\n", cnt);
    }
    return 0;
}

 

posted @ 2015-01-23 17:49  I'm coding  阅读(276)  评论(0编辑  收藏  举报