HDU 3232

You live in a village but work in another village. You decided to follow the straight path between your house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to the right of A, and all the rivers lie between them.

Fortunately, there is one "automatic" boat moving smoothly in each river. When you arrive the left bank of a river, just wait for the boat, then go with it. You're so slim that carrying you does not change the speed of any boat.

Days and days after, you came up with the following question: assume each boat is independently placed at random at time 0, what is the expected time to reach B from A? Your walking speed is always 1.

To be more precise, for a river of length L, the distance of the boat (which could be regarded as a mathematical point) to the left bank at time 0 is uniformly chosen from interval [0, L], and the boat is equally like to be moving left or right, if it’s not precisely at the river bank.

Input

There will be at most 10 test cases. Each case begins with two integers n and D, where n (0 <= n <= 10) is the number of rivers between A and B, D (1 <= D <= 1000) is the distance from A to B. Each of the following n lines describes a river with 3 integers: p, L and v (0 <= p < D, 0 < L <= D, 1 <= v <= 100). p is the distance from A to the left bank of this river, L is the length of this river, v is the speed of the boat on this river. It is guaranteed that rivers lie between A and B, and they don’t overlap. The last test case is followed by n=D=0, which should not be processed.

Output

For each test case, print the case number and the expected time, rounded to 3 digits after the decimal point.

Print a blank line after the output of each test case.

Sample Input

1 1
0 1 2
0 1
0 0

Sample Output

Case 1: 1.000

Case 2: 1.000
A,B相距D,A,B间有n条河,河宽Li,每条河上有一个速度为vi的船,在河山来回行驶,每条河离A的距离为pi,现在求从A到B时间的期望,步行速度始终为1;
船可以左右滑动;向左滑动的概率为1/2,向右滑动的概率1/2; 乘船所需时间 t= (1/2)*l/v+(1/2)*(l+l+l)/v[右移到河岸在回到左边再接人在回到右岸】
如果全都走路所需时间d*1;
走路时间+乘船时间-乘船那段距离走路需要的时间;

#include <cstdio>
#include <map>
#include <algorithm>
#include <string>
#include <cstring>
#include <iostream>
#include <vector>
#include <queue>
#include <list>
#include <cmath>
#include <set>
using namespace std;
const int maxn=50;
typedef long long ll;
struct boat
{
    double  p,l,v;
};
boat dv[maxn];
int main()
{
    int N;
    double D;
    int kase=0;
    while(scanf("%d%lf",&N,&D)&&(N+D))
    {
        double p,l,v;
        if(N==0)
        {
            printf("Case %d: %.3lf\n\n",++kase,D*1.000);
            continue;
        }
        double sum=0.000;
        sum+=D;
        for(int i=0; i<N; i++)
        {
            scanf("%lf%lf%lf",&p,&l,&v);
            double t=(1.000/2)*l/v+(1.000/2)*(l*3/v)-l;
            sum+=t;
        }
        printf("Case %d: %.3lf\n\n",++kase,sum);
    }
    return 0;
}


posted @ 2016-08-05 18:32  AC_dream  阅读(253)  评论(0编辑  收藏  举报