PAT 1114 Family Property

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ⋯Childk Mestate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child​i 's are the ID's of his/her children; M​estate​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:
For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVGsets AVGarea
​​

where ID is the smallest ID in the family; M is the total number of family members; AVGsets is the average number of sets of their real estate; and AVG​area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

分析
参考并查集简析

#include<iostream> //并查集的变形
#include<vector>
#include<set>
#include<algorithm>
#include<iomanip>
using namespace std;
struct family{
    int id, mid, fid, area, num;
    int cid[10];
}data[1005];
struct node{
    int id, people;
    double num, area; 
}ans[10000];
vector<int> peo(10000,0);
set<int> member, vec;
int findfather(int c){
    while(c!=peo[c])
        c=peo[c];
    return c;
}
void Union(int a, int b){
    int m=findfather(a);
    int n=findfather(b);
    if(m<n)
        peo[n]=m;
    else
        peo[m]=n;
}
bool cmp(const node& n1, const node& n2){
    return (n1.area!=n2.area?n1.area>n2.area:n1.id<n2.id);
}
int main(){
    int n, cn, cnt=0;
    cin>>n;
    for(int i=0; i<10000; i++)
        peo[i]=i;
    for(int i=0; i<n; i++){
        cin>>data[i].id>>data[i].fid>>data[i].mid>>cn;
        member.insert(data[i].id);
        if(data[i].fid!=-1){
            member.insert(data[i].fid);
            Union(data[i].id, data[i].fid);
        }
        if(data[i].mid!=-1){
            member.insert(data[i].mid);
            Union(data[i].id, data[i].mid);
        }
        for(int j=0; j<cn; j++){
            cin>>data[i].cid[j];
            member.insert(data[i].cid[j]);
            Union(data[i].id, data[i].cid[j]);
        }
        cin>>data[i].num>>data[i].area;
    }
    for(int i=0; i<n; i++){
        int t=findfather(data[i].id);
        ans[t].id=t;
        ans[t].num+=data[i].num;
        ans[t].area+=data[i].area;
        vec.insert(t);
    }
    for(auto it=member.begin(); it!=member.end(); it++)
        ans[findfather(*it)].people++;
    for(auto it=vec.begin(); it!=vec.end(); it++){
        ans[*it].area=double(ans[*it].area/ans[*it].people);
        ans[*it].num=double(ans[*it].num/ans[*it].people);
        cnt++;
    }
    sort(ans, ans+10000, cmp);
    cout<<cnt<<endl;
    for(int i=0; i<cnt; i++)
        cout<<setw(4)<<setfill('0')<<ans[i].id<<" "<<ans[i].people<<" "<<setiosflags(ios::fixed)<<setprecision(3)<<ans[i].num<<" "<<ans[i].area<<endl;
    return 0;
} 
posted @ 2018-08-19 18:07  A-Little-Nut  阅读(184)  评论(0编辑  收藏  举报