1069. The Black Hole of Numbers

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

#include<iostream>
#include<sstream>
#include<math.h>
#include<iomanip>
using namespace std;
void Insertion_sort(int a[],int N){
        int i,j; 
        for(i=1;i<N;i++){
              int temp=a[i];
             for(j=i;j>0;j--)
                  if(a[j-1]>temp) swap(a[j-1],a[j]);
                  else break;
             a[j]=temp;
        }
} 
int main(){
     string s;
     cin>>s;
     s.insert(0,4-s.length(),'0');
     int a[4];
     int r=0;
     while(r!=6174){
              int m=0,n=0;
              for(int i=0;i<4;i++)
                   a[i]=s[i]-'0';
              Insertion_sort(a,4);
              for(int i=0;i<4;i++){
                   m+=a[i]*pow(10,i);
                   n+=a[i]*pow(10,3-i);
              }
              r=m-n;
              cout<<setw(4)<<setfill('0')<<m;
              cout<<" - "; cout<<setw(4)<<setfill('0')<<n;
              cout<<" = "; cout<<setw(4)<<setfill('0')<<r<<endl;
              if(r==0) break;
              ostringstream os;
              os<<setw(4)<<setfill('0')<<r;
              s=os.str();
       }
       return 0; 
}
posted @ 2018-02-01 09:23  A-Little-Nut  阅读(226)  评论(0编辑  收藏  举报